Action-bar pull-down menus

Most of the displays used by the Z Abend Investigator ISPF interface include an action-bar located at the top of the panel. The ACTIONS ISPF command (by default mapped to PF6 on some displays) can be used to place the cursor at the left-most action available. Depending on ISPF settings, you might then be able to move the cursor to other actions by pressing the Tab key. Alternatively, you can simply use the Up/Down/Left/Right Arrow keys to place the cursor on the action of your choice. Using a PF key to issue the ACTIONS command is advantageous as the cursor is automatically repositioned in the display at the location where it was before the action was selected.

Once the cursor is placed on an action-bar item, press the Enter key to show the associated pull-down menu.

Options in pull-down menus can be selected by either entering the associated option number at the initial cursor position, or by placing the cursor (using the Up/Down/Left/Right Arrow keys) anywhere on the line of the option and pressing the Enter key. Any options not available for selection are indicated by an asterisk (*) instead of a numerical option number.

In the following list of available pull-down menu options, the format used is:
menu_name->menu_option->menu_option...
where
menu_name
The name of the action-bar pull-down menu at the top of the display.
menu_option
The name of the available option on the first and any subsequent menus.
The available pull-down menu options are show below in alphabetic order:
File->Analyze MVS™ Dump Data Set
Used to initiate interactive analysis of a SYSMDUMP or SVC dump data set. Primarily intended for CICS® system dump analysis (see Performing CICS system abend dump analysis) or Java™ dump analysis (see Performing Java analysis).
File->Change Fault History File Settings
Used to change the fault ID prefix or maximum number of fault entries history file settings. See Change fault history file settings.
File->Clear Last Accessed Information
Used to reset information about previously accessed history files or views, and previously accessed history file entries. See Resetting history file access information.
File->Exit
Selecting this option is the equivalent to issuing the ISPF EXIT command. Generally, this command ends the current display and returns to the display from which it was invoked.
File->Exit Z Abend Investigator
Used to exit from the Fault Entry List display. Selecting this option is equivalent to issuing the EXIT command (or pressing the PF3 key).
File->Exit Interactive Reanalysis
Used to return from anywhere in the interactive reanalysis report to the Fault Entry List display. Selecting this option is not equivalent to issuing the EXIT command (or pressing the PF3 key), as the EXIT command only returns to the previous display.
File->Fault Entry Information
Used to open the Fault Entry Information display as shown in Figure 1. Selecting this option is identical to issuing the INFO command (see INFO) or entering the "?" line command against a fault entry from the Fault Entry List display (see Applying an action to a particular fault).
File->Fault History File Properties
Used to display attribute and statistical information pertaining to the currently selected history file or view. See History file properties.
File->Format CICS Auxiliary Trace Data Set
Used to format a CICS auxiliary trace data set. See Formatting a CICS auxiliary trace data set.
File->Last Accessed Fault History File Entries
Used to display a list of up to 10 previously accessed history file entries. See Changing the history file or view displayed for more information.
File->Last Accessed Fault History Files or Views
Used to display a list of up to 10 previously accessed history files or views. See Changing the history file or view displayed.
File->List Views
Used to display a list of all available views. See Changing the history file or view displayed.
File->New Fault History File Allocation
Permits the allocation of a new history file. See New history file allocation for additional information.
Help->About Z Abend Investigator
Used to display copyright and general usage information for Z Abend Investigator. See Displaying product copyright, license, and version information.
Options->Batch Reanalysis Options
Used to set options for batch reanalysis. See Batch reanalysis options.
Options->Z Abend Investigator Preferences
Used to set options that affect the behavior of the Fault Entry List display. See Z Abend Investigator preferences.
Options->Interactive Reanalysis Options
Used to set options for interactive reanalysis. See Interactive reanalysis options for more information.
Services->Copy Current Display to Data Set
Used to copy the entire contents of the current display to a data set. See Copying interactive displays to a file.
Services->COBOL Explorer
Used to start the the COBOL Explorer dialog with prompt for program selection. See COBOL Explorer for more information.
Services->HFZS Subsystem Information
Used to invoke the interactive HFZS subsystem interface. See Using the interactive HFZS subsystem interface for more information.
Services->HFZLANGP Side File Formatting Utility
Used to invoke the HFZLANGP side file formatting utility to display a pseudo compiler listing.
Services->List User Notes
Used to show all user notes that exist for the current fault entry. Selecting this option is the equivalent to issuing the NOTELIST command. See Creating and managing user notes.
Services->Message ID Lookup
Used to show the explanation for a user-selected message, abend code, or other information. See Displaying user-selected message or abend code explanations for more information.
Services->Service Information
Used to show information about installation and maintenance status. See Step 3: Verify the service level (optional) in "Maintaining Z Abend Investigator" for more information.
Services->Storage Map
Used to show the layout of the current address space. See Displaying the address space storage map (STGMAP) for more information.
View->Add Blank Lines
Used to format displays by using blank lines when appropriate to separate the information that is shown. This value is the default. See Adding or removing blank lines.
View->Add Help Text
Used to add explanatory text to displays which might assist the inexperienced user. This value is the default. See Adding or removing help text for more information.
View->Add Pseudo Assembler Instructions
Used to add pseudo-assembler instructions to the Compiler Listing display. See Displaying source code for more information.
View->Column Configuration
Used to change the columns of information that are shown for faults listed on the Fault Entry List display. See Fault entry list column configuration for more information.
View->Preferred formatting Width
Used to set the preferred display formatting width. See Setting preferred formatting width.
View->Refresh
Used to reread all entries in the selected history file or view. See Refreshing fault entry information.
View->Remove Blank Lines
Used to eliminate blank lines as much as possible in displays to make the maximum amount of information visible on screens capable of only showing a small number of lines. See Adding or removing blank lines for more information.
View->Remove Help Text
Used to remove explanatory text from displays. See Adding or removing help text.
View->Remove Pseudo Assembler Instructions
Used to remove pseudo-assembler instructions from the Compiler Listing display. This value is the default. See Displaying source code.